Author Topic: Dehumidifers  (Read 9774 times)

Re: Dehumidifers
« Reply #125 on: December 11, 2017, 07:31:59 pm »
Two and a half years, by mistake because I kept meaning to do it. It didn't die, just got a bit dusty.

I think it was £22 for a pack of three activated carbon ones, they say they're good for four months of use, so not much for a year.
Just in case any ebac users have momentarily forgot which way the filters go in whilst they were changing them click here (at about 1:50).


Mrs Pingu

  • Who ate all the pies? Me
    • Twitter
Re: Dehumidifers
« Reply #126 on: December 11, 2017, 07:41:55 pm »
How often do ebac users change their filters? They are quite expensive (imo).

I thought that too!
Do not clench. It only makes it worse.

Mrs Pingu

  • Who ate all the pies? Me
    • Twitter
Re: Dehumidifers
« Reply #127 on: December 11, 2017, 07:42:39 pm »
Waiting for Ecoair to get back to me about the warranty....
Do not clench. It only makes it worse.

Mrs Pingu

  • Who ate all the pies? Me
    • Twitter
Re: Dehumidifers
« Reply #128 on: December 12, 2017, 04:15:15 pm »
Ecoair:
Quote
Dear Mrs Pingu,
Have you tried turning it on full, making sure it's on a flat surface, and that the collection bucket is empty and fully installed?
::-)
Do not clench. It only makes it worse.

Re: Dehumidifers
« Reply #129 on: December 12, 2017, 04:42:23 pm »
Just checked and confirmed that my ebac was purchased in Dec 2013 and it's still working fine. I did take advantage
of the five year guarantee which cost not a lot.


Edit: As it's a heavy item, if it has to be returned for guarantee repairs Ebac will arrange for a courier (DPD) to collect it free of charge.

Re: Dehumidifers
« Reply #130 on: December 12, 2017, 06:09:11 pm »
How often do ebac users change their filters? They are quite expensive (imo).

I thought that too!

Initially every 3 months when running it flat out but in recent times about once every two years.

Mrs Pingu

  • Who ate all the pies? Me
    • Twitter
Re: Dehumidifers
« Reply #131 on: December 12, 2017, 10:01:49 pm »
Ecoair:
Quote
Dear Mrs Pingu,
Have you tried turning it on full, making sure it's on a flat surface, and that the collection bucket is empty and fully installed?
::-)

Huh, now that I've got the box out of the shed to pack it up and send it back it appears to be working again....
I wonder if it is because it wasn't humid enough....  :-\
Do not clench. It only makes it worse.