General Category > GPS

Arghhh! - zero byte files

(1/2) > >>

SoreTween:
My Garmin Edge 310 has eaten 4 ride files, they are all zero bytes when attached as a storage device.  Is there any hope of getting them back?  Well, one I would like, the other 3 don't matter.  All 4 exist in the ride history list (date, duration, start time & distance shown) but if I try to open them they are empty as you'd expect.

Has anyone had any success using some kind of file recovery software on a Garmin?

[ETA] I know the routes got recorded OK because after I finished & saved the one I'm interested in recovering I went back into it to check the climb total, now lost.  It was later the corruption happened.  I suspect the Connect app screwed something up in a sync.  I've just found that several courses on the device, including this one, are also corrupt.

FifeingEejit:
From my memory of my edge 510, it doesn't write to the file as it goes so your whole ride is dependent on the device not fucking up when writing it from memory to flash memory... at the end.

But... If its managed to write it to the file system at some point then it may be the corruption is in that file system (its Fat or FAT32 isn't it?) not the raw storage so you may be ok.

And this sort of shit is what took me to wahoo...


Sent from my IV2201 using Tapatalk

Feanor:
I've had zero byte files on my old edge 800.
There was summary data in the devices history, but nothing more. I was not able to recover anything in these cases.

The common factor in each of these cases was me attempting to upload rides using a USB-OTG cable and an Android mobile device rather than a PC.

Every single time I have tried to use USB-OTG I've ended up with unrecoverable corrupted zero byte files on the device.
I no longer attempt this!

SoreTween:
Thanks Feanor, I too attempted USB-OTG upload from an android mobile.  The odd bit is I tested the process with a ride file that didn't matter before I left on this trip and it worked fine.  I'll not risk it again.

I've imaged the device's 20Mb.  All 3 hex editors I've tried to search it crash and my grep-fu is not up to binary searches. 

lissotriton:
Could try PhotoRec, see if it can find anything. https://www.cgsecurity.org/wiki/PhotoRec

Navigation

[0] Message Index

[#] Next page

Go to full version