Author Topic: ?dodgy Garmin edge 810  (Read 314 times)

?dodgy Garmin edge 810
« on: July 11, 2017, 07:55:18 pm »
My 810 has started playing up. On a tour last week, it randomly switched itself off once a day on each day of a 7 day trip. Something that happened very rarely previously, is now occurring daily. There is no particular pattern to it. It could be after 10km, 50km or more.
Is this terminal? Is there anything I can do to sort it, e.g. reset it, or do I have to contact Garmin?
Thanks.
I am often asked, what does YOAV stand for? It stands for Yoav On A Velo

Feanor

  • It's mostly downhill from here.
Re: ?dodgy Garmin edge 810
« Reply #1 on: July 11, 2017, 08:12:00 pm »
I have an 810 which I got whilst my 800 was waiting on parts.
I had exactly the same experience.

It's now relegated to backup duties only.

dim

Re: ?dodgy Garmin edge 810
« Reply #2 on: July 11, 2017, 08:33:10 pm »
you need to check the Garmin Forum :

https://forums.garmin.com/forum/into-sports/cycling/edge-810-aa

check what version of software you have and load the latest (only load it if there are no problems reported)

here's a thread from the garmin forum that may help:
https://forums.garmin.com/forum/into-sports/cycling/edge-810-aa/155039-


Re: ?dodgy Garmin edge 810
« Reply #3 on: July 13, 2017, 05:13:12 pm »
Mine's on the latest firmware (6.1) but according to some on the Garmin forum, that is the problem and they recommend downgrading to version 5.0 but I don't know how to do that.

I am just puzzled because I haven't changed anything on the Garmin for months and this problem just started last week. Today, it froze and switched itself off 3 times and none of my ride was recorded.
I am often asked, what does YOAV stand for? It stands for Yoav On A Velo