Author Topic: Veloviewer signature  (Read 327 times)

Veloviewer signature
« on: February 13, 2019, 09:27:04 am »
Towards the end of last year I noticed that my Veloviewer signature stats were not updating automatically. Since then I have been manually updating my YACF forum signature with the latest BB Code from Veloviewer after each significant ride.

It appears that most people on YACF who are using the Veloviewer signature still have their 2018 stats displayed (or have ridden a long way already in 2019). Has anything changed that means the automatic updates are no longer possible?

whosatthewheel

Re: Veloviewer signature
« Reply #1 on: February 13, 2019, 09:33:26 am »
... it's probably for the better to be honest...

Re: Veloviewer signature
« Reply #2 on: February 13, 2019, 09:59:42 am »
Thankfully this forum has an option to disable showing signatures. I can't stand them, way too much visual clutter. (I don't display avatars either.)

The BB Code from Veloviewer shouldn't really need to change each time since it only encodes the fields that are displayed. It's probably a caching issue and you're just being shown the old images rather than the updated ones.
"Yes please" said Squirrel "biscuits are our favourite things."

Re: Veloviewer signature
« Reply #3 on: February 13, 2019, 04:02:38 pm »
Thankfully this forum has an option to disable showing signatures. I can't stand them, way too much visual clutter.

I had to smile at that, since you have a signature within your profile. Disabling the signature was not something that I had realised was possible. Makes me wonder if it is also possible to block animations, which I currently do by using a broad brush blocking of posts from the people who use this. I'll check.

The BB Code from Veloviewer shouldn't really need to change each time since it only encodes the fields that are displayed. It's probably a caching issue and you're just being shown the old images rather than the updated ones.

I'm not sure that is the cause. I've tried clearing my cache, and also get the same outcome whichever device / browser I am using. But does make me think this might be a local issue rather than something everybody is experiencing.

Re: Veloviewer signature
« Reply #4 on: February 13, 2019, 04:25:48 pm »
Thankfully this forum has an option to disable showing signatures. I can't stand them, way too much visual clutter.

I had to smile at that, since you have a signature within your profile. Disabling the signature was not something that I had realised was possible. Makes me wonder if it is also possible to block animations, which I currently do by using a broad brush blocking of posts from the people who use this. I'll check.

I forget because I never see my own one. *checks*. It's a long time since I've read that book as my daughter has been able to read on her own for at least 5 years.

The BB Code from Veloviewer shouldn't really need to change each time since it only encodes the fields that are displayed. It's probably a caching issue and you're just being shown the old images rather than the updated ones.

I'm not sure that is the cause. I've tried clearing my cache, and also get the same outcome whichever device / browser I am using. But does make me think this might be a local issue rather than something everybody is experiencing.

The point is the URL of the image doesn't change as your mileage changes. Here's the default one for me:

https://veloviewer.com/SigImage/2511ea/1/5/M/p/abcdefghiz.png

2511ea is my athlete ID
1 is the number of rows
5 is the number of columns
M is metric units
p is 'positions' option for Graph values
abcdefghij are the default options for the 10 fields.

If the image isn't changing then either VV isn't updating it or it's being cached somewhere.
"Yes please" said Squirrel "biscuits are our favourite things."

Re: Veloviewer signature
« Reply #5 on: February 14, 2019, 09:35:07 am »
Mine wasn’t updating either. Binned it