Author Topic: Dependencies for Zoom on 32-bit Debian - SOLVED  (Read 552 times)

Dependencies for Zoom on 32-bit Debian - SOLVED
« on: March 18, 2020, 08:26:42 am »
I'm trying to install the Zoom software on 32-bit Linux running Debian, and this requires ibus, which in turn has a whole load of dependencies.  When I've tried previously to install this, each 'sub'program' has more dependencies.  Is there a way I can approach the task to minimise this recursion, eg through the order of tackling it?  Why isn't ibus in the Debian built-in software list?

I can actually use Zoom without installing this software, but not running it through a browser is probably more efficient, so it would be good if this were possible.

Re: Dependencies for Zoom on 32-bit Debian
« Reply #1 on: March 18, 2020, 09:15:04 pm »
How are you installing it?
Have you downloaded a .deb file?

If you are using Debian Stretch or newer, you could try
Code: [Select]
sudo apt install ./foo-1.2.3.deb
If you are using Debian Jessie or older, you could try
Code: [Select]
dpkg -i mypackage.deb
apt-get install -f --fix-missing

Otherwise, look at gdebi
A Few Apples Short of a Strudel

Re: Dependencies for Zoom on 32-bit Debian
« Reply #2 on: March 18, 2020, 09:40:25 pm »
ibus is available in Debian:

https://packages.debian.org/search?keywords=ibus

Are you trying to install using "dpkg -i foo.deb"?  You are better of using "apt install ./foo.deb" (note the "./") which will automatically install dependencies if available.

Kim

  • Timelord
Re: Dependencies for Zoom on 32-bit Debian
« Reply #3 on: March 18, 2020, 09:46:35 pm »
Are you trying to install using "dpkg -i foo.deb"?  You are better of using "apt install ./foo.deb" (note the "./") which will automatically install dependencies if available.

How did I not know you could do that?  Thanks.
Careful, Kim. Your sarcasm's showing...

Re: Dependencies for Zoom on 32-bit Debian
« Reply #4 on: March 18, 2020, 10:15:34 pm »
Thank you, Philip.  That's just what I needed.

I ran
Code: [Select]
lsb_release -a

giving the result
Code: [Select]
No LSB modules are available.
Distributor ID: Debian
Description: Debian GNU/Linux 9.11 (stretch)
Release: 9.11
Codename: stretch

then I ran
Code: [Select]
apt install ./zoom_i386.deb

and all went well. :thumbsup: :thumbsup: :thumbsup:

Re: Dependencies for Zoom on 32-bit Debian
« Reply #5 on: March 21, 2020, 08:05:27 pm »
Are you trying to install using "dpkg -i foo.deb"?  You are better of using "apt install ./foo.deb" (note the "./") which will automatically install dependencies if available.

How did I not know you could do that?  Thanks.

it was a recent innovation, apt 1.1 / stretch
A Few Apples Short of a Strudel