Author Topic: Workflow does not work any more  (Read 3109 times)

frankly frankie

  • I kid you not
    • Fuchsiaphile
Re: Workflow does not work any more
« Reply #25 on: October 18, 2010, 01:17:43 pm »
Surely if you open the .gpx file in Mapsource and then Save it - it will save as .gdb by default and WinGDB should them be able to work with it.

I suppose if it is a very recent version of Mapsource it could be saving a newly non-compatible version of .gdb - ie > v3 - in which case just choose v2 in the file type dropdown.

(When sharing .gdb files, I always save them as v2, because a lot of people have earlier versions of Mapsource that can't read the default v3 format.)
It's not dark yet but it's getting there.

Wothill

  • over the hills and far away
Re: Workflow does not work any more
« Reply #26 on: October 18, 2010, 01:23:44 pm »
Surely if you open the .gpx file in Mapsource and then Save it - it will save as .gdb by default and WinGDB should them be able to work with it.
Ah. Of course! Thanks, that's the final link. Back in action with Tracks and Routes. Now, where did I leave my bike?

Re: Workflow does not work any more
« Reply #27 on: October 18, 2010, 07:37:44 pm »
What version of GMap2GPX are you using ?  6.4b causes the problem I illustrated. 6.4c is available which fixes it. The author talks about it on his website yesterday,
GMapToGPX » Communications From Elsewhere
and it's what I said upthread. Scroll down to the last few comments.

 It's not Mapsource that's the problem nor Wingdb3 it's GMap2GPX generating invalid XML, because Google changed something

Wothill

  • over the hills and far away
Re: Workflow does not work any more
« Reply #28 on: October 18, 2010, 10:34:38 pm »
What version of GMap2GPX are you using ?  6.4b causes the problem I illustrated. 6.4c is available which fixes it. The author talks about it on his website yesterday,
GMapToGPX » Communications From Elsewhere
and it's what I said upthread. Scroll down to the last few comments.

 It's not Mapsource that's the problem nor Wingdb3 it's GMap2GPX generating invalid XML, because Google changed something
Thanks, Mr N, I'll look into that - it was 6.4b. Strange thing is though that the problem is new. I have been using this procedure for a year without any problem (except that my intro to WINGDB was recent for getting proper waypoints). Or is 6.4b also new? I assumed that since it looked like a web link to GMAPtoGPX, any version change would be automatic at their end.

Re: Workflow does not work any more
« Reply #29 on: October 18, 2010, 10:40:13 pm »
It's not Mapsource that's the problem nor Wingdb3 it's GMap2GPX generating invalid XML, because Google changed something

Excellent! Thanks for the info. I love threads like this. Even when I'm wrong. Mine was an old version too and I'd never have realised it had been updated.


frankly frankie

  • I kid you not
    • Fuchsiaphile
Re: Workflow does not work any more
« Reply #30 on: October 19, 2010, 11:29:12 am »
That explains why the workflow still works for me - the GMapstoGPX javascript snippet is just a bookmark in my browser, and when I use it, the xml code that is generated has
Code: [Select]
<gpx version="1.1"     creator="GMapToGPX 6.4c as part of the header.
As wothill supposed, the update is automatic at their end - or it was for me anyway.  I've used the utility a few times over the past 2 weeks and not noticed any problems. Or maybe I'm just so used to a few stumbles (because Mapsource is very intolerant) and just pass the .gpx through EasyGPS or GPSBabel without even thinking about it - both of these utilities are very good at cleaning dodgy code.
It's not dark yet but it's getting there.

Re: Workflow does not work any more
« Reply #31 on: October 20, 2010, 08:44:34 pm »
What version of GMap2GPX are you using ?  6.4b causes the problem I illustrated. 6.4c is available which fixes it. The author talks about it on his website yesterday,
GMapToGPX &raquo; Communications From Elsewhere
and it's what I said upthread. Scroll down to the last few comments.

 It's not Mapsource that's the problem nor Wingdb3 it's GMap2GPX generating invalid XML, because Google changed something
Thanks, Mr N, I'll look into that - it was 6.4b. Strange thing is though that the problem is new. I have been using this procedure for a year without any problem (except that my intro to WINGDB was recent for getting proper waypoints). Or is 6.4b also new? I assumed that since it looked like a web link to GMAPtoGPX, any version change would be automatic at their end.
No it's not a weblink ad Frankie says it's a bookmarklet, just some local javascript actually. The problem was caused by Google, their change caused GMap2GPX to do something stupid so 6.4b was working fine for ages, over a year, then suddenly it goes wrong because Google changed the inputs. We had this old phrase GIGO, Garbage In Garbage Out. I don't use GMap2GPX much but remember reading that it was suseptable to changes by Google.