Author Topic: Garmin Edge 1030 navigation failing  (Read 2044 times)


Garmin Edge 1030 navigation failing
« on: 16 November, 2020, 09:39:57 am »
I’ve had this twice recently and it seems from the Garmin forums and it seems I’m not alone. Basically the navigation prompts stop after a while - it was around 55km yesterday. This while following a route synced from Strava. The weekend before it happened with a route from RideWithGPS. It gets stuck at a certain instruction and won’t shift.

I tried restarting navigation of the route last weekend. No joy. Then it was stuck at the start of the route. I followed the pink line on the map for a while then once I was headed for home I switched to navigate to home address which worked fine.

It may be new in the 10.20 firmware as others reporting the issue say it started with 10.20. If you are offered an update to this revision maybe don’t take it. I wonder if it’s possible to roll back.

Re: Garmin Edge 1030 navigation failing
« Reply #1 on: 16 November, 2020, 12:43:57 pm »
I've something similar on an Edge 1000 on the last couple of 200s I rode, though at the start of the ride rather than mid-way. My position was 'stuck' until I cycled screens, after which it would update and then stick again, and there were no TBT instructions.

I put this down to a bad GPX file that I've since updated (but have yet to try), but thinking about it now, a firmware glitch seems more likely. Not sure what version I was on when this first happened a few months ago, but I'm now on 15.50.

frankly frankie

  • I kid you not
    • Fuchsiaphile
Re: Garmin Edge 1030 navigation failing
« Reply #2 on: 16 November, 2020, 06:05:03 pm »
Sounds a bit like a non-standard character found its way into the instructions embedded in the GPX.  But that would be more likely in France or somewhere where a lot of place names have odd accents.  And in that case more likely the GPX wouldn't load at all.
when you're dead you're done, so let the good times roll


Re: Garmin Edge 1030 navigation failing
« Reply #3 on: 17 November, 2020, 06:31:58 pm »
A post suggests 10.26 beta fixes the issue. But introduces a bug where it powers off after an hour. At least you can restart from where you left off with this.

I don’t think it’s specific to any location. The two places I had issues were on different routes that had little in common and the places they failed were 10+ miles apart.


Re: Garmin Edge 1030 navigation failing
« Reply #4 on: 18 November, 2020, 07:29:01 pm »
I get this now and then.  TBT is a bit hit and miss so I tend to just follow the line.  It soon bleeps if you miss a turn.

It has randomly shut down on me a couple of times, but picks everything back up when you turn it back on.


Re: Garmin Edge 1030 navigation failing
« Reply #5 on: 21 November, 2020, 11:36:25 pm »
Just updated to 11.00 and I have a route to ride tomorrow - let's see how that goes.