Author Topic: Zoom audio problems on Linux Manjaro  (Read 698 times)

nicknack

  • Hornblower
Zoom audio problems on Linux Manjaro
« on: December 12, 2020, 04:33:54 pm »
Moving over from random computery things thread.

This would be a rant if ICBA, but I can't.

After much swearing my small HP box is now happily(?) running Manjaro (Linux). Everything apart from one thing seems to be fine. The one thing involves video calls either via Zoom or Messenger.

I can hear them but they can't hear me.

There's nothing wrong with the mic on the webcam (it's just cheap and crappy but I can record with it no problem). If I check it with the setup page on Zoom then it says it's working fine. But not when I try to speak to someone. The signal's there but it ain't going anywhere. Obviously it's not muted and volume's way up. Up to a couple of weeks ago it all worked fine but then Ubuntu decided it didn't want to play anymore so I went non-debian.

I've run out of things to try. Anyone got any ideas? Please.

Do you know if manjaro using pulse audio?
Yes, it is.

Might I suggest you explain the issue in a seperate thread and include with the first post the output of running pacmd list-sources in the terminal?
BTW I've not had a problem like this before, so I've no idea what the solution is going to be! Could you also say whether you are using Zoom in the browser or the Zoom application.
Will do. Thanks.

I've tried both methods of using Zoom and also Facebook Messenger video. All have the same issue.

Output of pacmd list-sources

Quote
[nick@nick-hp260g2dm ~]$ pacmd list-sources
2 source(s) available.
  * index: 0
   name: <alsa_output.pci-0000_00_1f.3.analog-stereo.monitor>
   driver: <module-alsa-card.c>
   flags: DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
   state: SUSPENDED
   suspend cause: IDLE
   priority: 1030
   volume: front-left: 65536 / 100% / 0.00 dB,   front-right: 65536 / 100% / 0.00 dB
           balance 0.00
   base volume: 65536 / 100% / 0.00 dB
   volume steps: 65537
   muted: no
   current latency: 0.00 ms
   max rewind: 0 KiB
   sample spec: s16le 2ch 44100Hz
   channel map: front-left,front-right
                Stereo
   used by: 0
   linked by: 0
   configured latency: 0.00 ms; range is 0.50 .. 2000.00 ms
   monitor_of: 0
   card: 0 <alsa_card.pci-0000_00_1f.3>
   module: 6
   properties:
      device.description = "Monitor of Built-in Audio Analog Stereo"
      device.class = "monitor"
      alsa.card = "0"
      alsa.card_name = "HDA Intel PCH"
      alsa.long_card_name = "HDA Intel PCH at 0xef220000 irq 129"
      alsa.driver_name = "snd_hda_intel"
      device.bus_path = "pci-0000:00:1f.3"
      sysfs.path = "/devices/pci0000:00/0000:00:1f.3/sound/card0"
      device.bus = "pci"
      device.vendor.id = "8086"
      device.vendor.name = "Intel Corporation"
      device.product.id = "9d70"
      device.product.name = "Sunrise Point-LP HD Audio"
      device.form_factor = "internal"
      device.string = "0"
      module-udev-detect.discovered = "1"
      device.icon_name = "audio-card-pci"
    index: 1
   name: <alsa_input.pci-0000_00_1f.3.analog-stereo>
   driver: <module-alsa-card.c>
   flags: HARDWARE HW_MUTE_CTRL HW_VOLUME_CTRL DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
   state: SUSPENDED
   suspend cause: IDLE
   priority: 9039
   volume: front-left: 48574 /  74% / -7.80 dB,   front-right: 48574 /  74% / -7.80 dB
           balance 0.00
   base volume: 6554 /  10% / -60.00 dB
   volume steps: 65537
   muted: no
   current latency: 0.00 ms
   max rewind: 0 KiB
   sample spec: s16le 2ch 44100Hz
   channel map: front-left,front-right
                Stereo
   used by: 0
   linked by: 0
   configured latency: 0.00 ms; range is 0.50 .. 2000.00 ms
   card: 0 <alsa_card.pci-0000_00_1f.3>
   module: 6
   properties:
      alsa.resolution_bits = "16"
      device.api = "alsa"
      device.class = "sound"
      alsa.class = "generic"
      alsa.subclass = "generic-mix"
      alsa.name = "ALC221 Analog"
      alsa.id = "ALC221 Analog"
      alsa.subdevice = "0"
      alsa.subdevice_name = "subdevice #0"
      alsa.device = "0"
      alsa.card = "0"
      alsa.card_name = "HDA Intel PCH"
      alsa.long_card_name = "HDA Intel PCH at 0xef220000 irq 129"
      alsa.driver_name = "snd_hda_intel"
      device.bus_path = "pci-0000:00:1f.3"
      sysfs.path = "/devices/pci0000:00/0000:00:1f.3/sound/card0"
      device.bus = "pci"
      device.vendor.id = "8086"
      device.vendor.name = "Intel Corporation"
      device.product.id = "9d70"
      device.product.name = "Sunrise Point-LP HD Audio"
      device.form_factor = "internal"
      device.string = "front:0"
      device.buffering.buffer_size = "352800"
      device.buffering.fragment_size = "176400"
      device.access_mode = "mmap+timer"
      device.profile.name = "analog-stereo"
      device.profile.description = "Analog Stereo"
      device.description = "Built-in Audio Analog Stereo"
      module-udev-detect.discovered = "1"
      device.icon_name = "audio-card-pci"
   ports:
      analog-input-mic: Microphone (priority 8700, latency offset 0 usec, available: yes)
         properties:
            device.icon_name = "audio-input-microphone"
   active port: <analog-input-mic>
There's no vibrations, but wait.

Kim

  • Timelord
Re: Zoom audio problems on Linux Manjaro
« Reply #1 on: December 12, 2020, 04:36:54 pm »
If Zoom's getting the audio in test mode, it doesn't sound like a microphone problem.  ???
Careful, Kim. Your sarcasm's showing...

nicknack

  • Hornblower
Re: Zoom audio problems on Linux Manjaro
« Reply #2 on: December 12, 2020, 04:40:36 pm »
If Zoom's getting the audio in test mode, it doesn't sound like a microphone problem.  ???
Well yes. I can speak into the mic and record it but it doesn't want to send it over the interwebs.
There's no vibrations, but wait.

Kim

  • Timelord
Re: Zoom audio problems on Linux Manjaro
« Reply #3 on: December 12, 2020, 05:07:35 pm »
If Zoom's getting the audio in test mode, it doesn't sound like a microphone problem.  ???
Well yes. I can speak into the mic and record it but it doesn't want to send it over the interwebs.

That's got to be Zoom's fault, shirley?  Rather than Pulseaudio or whatever's breaking sound on Linux this month.  *boggle*
Careful, Kim. Your sarcasm's showing...

nicknack

  • Hornblower
Re: Zoom audio problems on Linux Manjaro
« Reply #4 on: December 12, 2020, 05:13:59 pm »
If Zoom's getting the audio in test mode, it doesn't sound like a microphone problem.  ???
Well yes. I can speak into the mic and record it but it doesn't want to send it over the interwebs.

That's got to be Zoom's fault, shirley?  Rather than Pulseaudio or whatever's breaking sound on Linux this month.  *boggle*
And Facebook Messenger?
There's no vibrations, but wait.

nicknack

  • Hornblower
Re: Zoom audio problems on Linux Manjaro
« Reply #5 on: December 12, 2020, 05:24:16 pm »
Just in case anyone was wondering, it's not peculiar to the Isle of Sheppey. My phone works fine with all of it going through the same internet connection. It's just this stupid HP computer - although I fail to see how it could be a hardware problem. I'd hazard a guess that it's some little change that I need to make somewhere but I'm not seeing it.
There's no vibrations, but wait.

Kim

  • Timelord
Re: Zoom audio problems on Linux Manjaro
« Reply #6 on: December 12, 2020, 05:45:41 pm »
If Zoom's getting the audio in test mode, it doesn't sound like a microphone problem.  ???
Well yes. I can speak into the mic and record it but it doesn't want to send it over the interwebs.

That's got to be Zoom's fault, shirley?  Rather than Pulseaudio or whatever's breaking sound on Linux this month.  *boggle*
And Facebook Messenger?

That's where it stops making sense...
Careful, Kim. Your sarcasm's showing...

Re: Zoom audio problems on Linux Manjaro
« Reply #7 on: December 12, 2020, 05:59:05 pm »
We have a friend who suffers endless problems with Zoom and transmitting her voice.  Sometimes it works, sometimes it just doesn't.  I will check with her what make her laptop is.  She spends inordinate amounts of time fiddling with the settings in both Windows itself and in  Zoom.

Her partner's laptop which is also a Windows 10 machine just works.

Re: Zoom audio problems on Linux Manjaro
« Reply #8 on: December 12, 2020, 06:19:34 pm »
Are you sure its using the right mic ?

I just tried Zoom on Ubuntu 20.04 and it picked the laptops inbuilt mic and not the headset one.  Had to go into the Zoom audio settings and pick the headset mic from the pull down menu.
I think you'll find it's a bit more complicated than that.

nicknack

  • Hornblower
Re: Zoom audio problems on Linux Manjaro
« Reply #9 on: December 12, 2020, 06:40:28 pm »
I've only got one mic. When I test it in Zoom it shows up and works fine.
There's no vibrations, but wait.

Re: Zoom audio problems on Linux Manjaro
« Reply #10 on: December 12, 2020, 06:50:45 pm »
If Zoom's getting the audio in test mode, it doesn't sound like a microphone problem.  ???

Not suggesting it is, I just wanted to see the devices PulseAudio recognised and which is the current.
I've had a great deal of fun with this lately, with output (sinks) rather than inputs (sources).
A Few Apples Short of a Strudel

Re: Zoom audio problems on Linux Manjaro
« Reply #11 on: December 12, 2020, 07:19:45 pm »
Sorry if I'm being terribly stupid here, but I think this might be the combination of the selected source device being "alsa_output.pci-0000_00_1f.3.analog-stereo.monitor" (index: 0, denoted with an asterisk) and the way Zoom plays with microphones.

On a recently rebuilt Debian 10 laptop, I have source index 1 alsa_input.pci-0000_00_1b.0.analog-stereo as the default source and source index 0 alsa_output.pci-0000_00_1b.0.analog-stereo.monitor as a monitor/virtual device. I've changed the monitor/virtual device to be the default sink as per nicknack's setup with pacmd set-default-source 0 and I can reproduce the issue. If I revert back, it is fine again: pacmd set-default-source 1

I'm an absolutely novice when it comes to doing anything with PulseAudio, but it seems odd to me that the virtual/monitor device is the default source (input)? I could 100% missing the point.
A Few Apples Short of a Strudel

nicknack

  • Hornblower
Re: Zoom audio problems on Linux Manjaro
« Reply #12 on: December 12, 2020, 08:39:54 pm »
I'll give it a go tomorrow. Ta.
There's no vibrations, but wait.

FifeingEejit

  • Not Small
Re: Zoom audio problems on Linux Manjaro
« Reply #13 on: December 12, 2020, 10:41:27 pm »
Someone in my hiking club (FOTP) has microphone problems on Zoom in Linux.
Starts as an inaudible tinny version of his voice before it becomes normal after a few seconds

nicknack

  • Hornblower
Re: Zoom audio problems on Linux Manjaro
« Reply #14 on: December 13, 2020, 09:50:40 am »
Sorry if I'm being terribly stupid here, but I think this might be the combination of the selected source device being "alsa_output.pci-0000_00_1f.3.analog-stereo.monitor" (index: 0, denoted with an asterisk) and the way Zoom plays with microphones.

On a recently rebuilt Debian 10 laptop, I have source index 1 alsa_input.pci-0000_00_1b.0.analog-stereo as the default source and source index 0 alsa_output.pci-0000_00_1b.0.analog-stereo.monitor as a monitor/virtual device. I've changed the monitor/virtual device to be the default sink as per nicknack's setup with pacmd set-default-source 0 and I can reproduce the issue. If I revert back, it is fine again: pacmd set-default-source 1

I'm an absolutely novice when it comes to doing anything with PulseAudio, but it seems odd to me that the virtual/monitor device is the default source (input)? I could 100% missing the point.
It works!
Thanks very much for that.
Linux being stupid about how it handles audio again I suppose.

In the Pulseaudio GUI before, it looked like it was giving me an option to switch between the two but it was stuck on one and wouldn't change. I assumed that was correct for what it was trying to do. I might have known the terminal would be involved. Having effected the change the option is no longer there in the GUI.
There's no vibrations, but wait.

Re: Zoom audio problems on Linux Manjaro
« Reply #15 on: December 13, 2020, 12:59:00 pm »
Sorry if I'm being terribly stupid here, but I think this might be the combination of the selected source device being "alsa_output.pci-0000_00_1f.3.analog-stereo.monitor" (index: 0, denoted with an asterisk) and the way Zoom plays with microphones.

On a recently rebuilt Debian 10 laptop, I have source index 1 alsa_input.pci-0000_00_1b.0.analog-stereo as the default source and source index 0 alsa_output.pci-0000_00_1b.0.analog-stereo.monitor as a monitor/virtual device. I've changed the monitor/virtual device to be the default sink as per nicknack's setup with pacmd set-default-source 0 and I can reproduce the issue. If I revert back, it is fine again: pacmd set-default-source 1

I'm an absolutely novice when it comes to doing anything with PulseAudio, but it seems odd to me that the virtual/monitor device is the default source (input)? I could 100% missing the point.
It works!
Thanks very much for that.
Linux being stupid about how it handles audio again I suppose.

In the Pulseaudio GUI before, it looked like it was giving me an option to switch between the two but it was stuck on one and wouldn't change. I assumed that was correct for what it was trying to do. I might have known the terminal would be involved. Having effected the change the option is no longer there in the GUI.

The next step will be add the following line to the end of /etc/pulse/default.pa to make it persist a reboot. I think the following should do it (on account I'm not sure it needs the angled brackets or not):
Code: [Select]
set-default-source alsa_input.pci-0000_00_1f.3.analog-stereo

You will need to do something like:
sudo nano /etc/pulse/default.pa

or:
sudo vi /etc/pulse/default.pa

to open the file for editing, substituting nano/vi for your favourite text editor. If you don't have one, I think nano should do.
A Few Apples Short of a Strudel

Re: Zoom audio problems on Linux Manjaro
« Reply #16 on: December 13, 2020, 01:00:23 pm »
Also noticed I didn't see the webcam microphone in the list of inputs (sinks). The microphone you are using looks like it is build into the laptop or plugged into a jack on the laptop?
A Few Apples Short of a Strudel

Re: Zoom audio problems on Linux Manjaro
« Reply #17 on: December 13, 2020, 01:13:00 pm »
The next step will be add the following line to the end of /etc/pulse/default.pa to make it persist a reboot.
If you want to leave the system files unchanged, you can create .config/pulse/default.pa in your home directory. It needs to start with the line:
.include /etc/pulse/default.pa
followed by the set-default-source line.

nicknack

  • Hornblower
Re: Zoom audio problems on Linux Manjaro
« Reply #18 on: December 13, 2020, 01:40:46 pm »
Also noticed I didn't see the webcam microphone in the list of inputs (sinks). The microphone you are using looks like it is build into the laptop or plugged into a jack on the laptop?
It's not a laptop it's a small form factor PC (HP) and, yes, it's a separate webcam and mic.

Thanks for the suggestions all. I'll have a fiddle with the defaults.
There's no vibrations, but wait.